Platform performance degradation
Incident Report for MultiSafepay
Resolved
Performance is back to normal and we will continue to monitor the services.
Posted Nov 27, 2020 - 10:47 CET
Update
The performance of the API is back to normal. We're continuing to work on resolving the remaining issue
Posted Nov 27, 2020 - 10:38 CET
Identified
We have identified the issue and are working on resolving the issue
Posted Nov 27, 2020 - 10:29 CET
Investigating
Payment notifications are experiencing degraded performance. We are aware of the issue(s) and our team is investigating, we will update as soon as possible.
Posted Nov 27, 2020 - 10:16 CET
This incident affected: API and Payments.