PayPal transactions are unavailable
Incident Report for MultiSafepay
Resolved
The incident seems to be resolved. Our team will keep monitoring the situation with PayPal.
Posted Jun 02, 2020 - 09:32 CEST
Identified
PayPal transactions are unavailable and PayPal is reporting global issues. Our team is currently monitoring the situation.
Posted Jun 02, 2020 - 09:10 CEST
This incident affected: Payments.