Afterpay elevated error rate
Incident Report for MultiSafepay
Resolved
The incident has been resolved and the transaction rates have returned to normal.
Posted Mar 17, 2022 - 22:01 CET
Identified
Together with Afterpay our team is working on resolving the situation. Once more information is available we'll update here.
Posted Mar 17, 2022 - 12:30 CET
Investigating
We have identified that Afterpay transactions are experiencing an elevated error rate and our team is currently investigating the issue.
Posted Mar 17, 2022 - 10:28 CET
This incident affected: Payments.