Paypal performance degradation
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted May 28, 2020 - 14:44 CEST
Identified
Paypal is experiencing a performance degradation. Our team is currently standing by as PayPal reported global issues.
Posted May 28, 2020 - 14:35 CEST
This incident affected: Payments.