iDEAL transactions unavailable via Rabobank
Incident Report for MultiSafepay
Resolved
The incident at Rabobank seems to have be resolved. Our teams will closely monitor the situation.
Posted May 29, 2020 - 19:14 CEST
Identified
Due to issues with the issuer Rabobank iDEAL transactions with this bank are not possible at this moment. The other banks are not affected. We are closely monitoring the situation.
Posted May 29, 2020 - 18:20 CEST
This incident affected: Payments.