Belfius payments unavailable
Incident Report for MultiSafepay
Resolved
The incident appears to be resolved by Belfius as Belfius payments are returning to their normal levels.
We will monitor the situation closely.
Posted Nov 27, 2020 - 16:19 CET
Monitoring
Belfius has reported that the webbrowser / PC payments are performing as expected, the Belfius Mobile app still has unresolved issues with payment.
Belfius is still resolving the issue and we will update as soon as possible.
Posted Nov 27, 2020 - 14:57 CET
Identified
Due to an issue at Belfius, the payment method is experiencing an outage. As a result, Belfius payments are not being completed.
Belfius is trying to resolve the issue and we will update as soon as possible.
Posted Nov 27, 2020 - 13:51 CET
This incident affected: Payments.