Support connectivity performance degradation
Incident Report for MultiSafepay
Resolved
The incident has been resolved
Posted Jul 12, 2021 - 18:48 CEST
Identified
Our customer and operations teams are experiencing connectivity issues, hampering our ability to address your questions and inquiries directly. Payments are not impacted.
We are aware of the issue(s) and our team is investigating and will update as soon as possible.
Our apologies for any inconvenience this may cause.
Posted Jul 12, 2021 - 16:22 CEST
This incident affected: Customer Support.