Bancontact major performance degradation
Incident Report for MultiSafepay
Resolved
The incident has been resolved.
Posted Sep 05, 2024 - 10:38 CEST
Investigating
We're investigating the root cause of a major performance degradation of Bancontact transactions.
We'll update as information comes available
Posted Sep 05, 2024 - 08:03 CEST
This incident affected: Payments.