Platform performance degradation
Incident Report for MultiSafepay
Resolved
The incident has been resolved. We'll continue the monitor the situation closely
Posted Apr 12, 2022 - 08:08 CEST
Investigating
Our Payment Pages are experiencing degraded performance. We are aware of the issue(s) and our team is investigating, we will update as soon as possible.
Posted Apr 12, 2022 - 06:30 CEST
This incident affected: Payments and MultiSafepay app.