Bancontact payments - performance degradation

Incident Report for MultiSafepay

Resolved

The incident has been resolved. We're investigating the root cause
Posted Jul 21, 2021 - 10:08 CEST

Investigating

Currently under investigation is a performance degradation in Bancontact payments.
Posted Jul 21, 2021 - 10:06 CEST
This incident affected: Payments.