iDEAL performance issues identified at issuer ABN AMRO
Incident Report for MultiSafepay
Resolved
The incident has been resolved
Posted Jul 01, 2024 - 17:13 CEST
Identified
We have identified a performance drop in iDEAL payment with issuer ABN AMRO, we're monitoring the situation.

For more details check:
https://beschikbaarheid.ideal.nl/
Posted Jul 01, 2024 - 16:54 CEST
This incident affected: Payments.