Bancontact payments - performance degradation due to 3DS failure
Incident Report for MultiSafepay
Resolved
Bancontact 3D verification is back at normal levels again, however we will monitor the situation closely.
If there is more relevant information from Bancontact on this issue we will update the page accordingly.
Posted Jul 29, 2021 - 14:51 CEST
Identified
Bancontact still has issues with the 3D verification. We are awaiting resolution by Bancontact and as it is an external issue, we will update this page as soon as more information becomes available.
Posted Jul 29, 2021 - 13:57 CEST
Investigating
Bancontact is experiencing issues with handling 3D verification. We're investigating the situation and awaiting update from Bancontact.
Posted Jul 29, 2021 - 10:46 CEST
This incident affected: Payments.