MasterCard performance degradation - payment conversion affected
Incident Report for MultiSafepay
Resolved
The incident has been resolved by MasterCard.
Posted Apr 23, 2023 - 20:34 CEST
Investigating
We have identified an issue with MasterCard transactions outside of our infrastructure since 17:10 CEST Currently we're monitoring the situation and awaiting resolution by MasterCard. Payment performance is affected for MasterCard transactions.
Posted Apr 23, 2023 - 18:10 CEST
This incident affected: Payments.