iDEAL performance issues identified at issuer ABN AMRO

Incident Report for MultiSafepay

Resolved

The incident has been resolved, we're keeping track of any flare ups

For more details:
https://availability.ideal.nl/
Posted Jul 06, 2026 - 17:00 CEST

Investigating

iDEAL performance issues have reoccurred at ABN AMRO.

For more details:
https://availability.ideal.nl/
Posted Jul 06, 2026 - 16:43 CEST
This incident affected: Payments.