3D Secure elevated error rate

Incident Report for MultiSafepay

Resolved

The incident has been resolved since 14:45 CET
Posted Dec 19, 2022 - 15:04 CET

Monitoring

Performance rates have returned to regular levels. Our team will remain monitoring the situation closely and close later if it remains stable.
Posted Dec 19, 2022 - 14:54 CET

Investigating

3D Secure is performing below threshold values. We are investigating root cause.
Posted Dec 19, 2022 - 14:38 CET
This incident affected: Payments.