iDEAL performance issues with ABN AMRO

Incident Report for MultiSafepay

Resolved

The incident has been resolved around 10:00 CEST. For more details, please see: https://availability.ideal.nl/History?bank=ABN_AMRO
Posted Oct 27, 2022 - 12:15 CEST

Identified

iDEAL is experiencing severe issues with processing ABN AMRO bank transactions. This issue is outside of our platform and we're awaiting resolution by ABN AMRO or iDEAL. For more information; https://availability.ideal.nl/
Posted Oct 27, 2022 - 09:01 CEST
This incident affected: Payments.