Belfius payments unavailable
Incident Report for MultiSafepay
Resolved
The incident appears to be resolved by Belfius as payments are returning to their normal levels.
We will monitor the situation closely.
Posted Mar 15, 2021 - 19:07 CET
Identified
Due to an issue at Belfius, the payment method is experiencing an outage. As a result, Belfius payments are not being completed.
Belfius is trying to resolve the issue and we will update as soon as possible.
Posted Mar 15, 2021 - 15:30 CET
This incident affected: Payments.