[iDEAL] Outage of iDEAL
Incident Report for MultiSafepay
Resolved
The incident has been resolved by iDEAL.

For more details: https://availability.ideal.nl/
Posted Oct 22, 2024 - 16:59 CEST
Identified
Currently iDEAL is experiencing a full outage. We are awaiting fix.

More details will be published once available.

iDEAL availability page: https://availability.ideal.nl/
Posted Oct 22, 2024 - 16:55 CEST
This incident affected: Payments.