Partial outage - Payment method performance degradation

Incident Report for MultiSafepay

Resolved

The incident is resolved and closed. A review will follow to address root cause and prevention.
Posted Apr 15, 2026 - 08:57 CEST

Update

The incident has been resolved and our team is currently monitoring the situation before closing the incident.
Posted Apr 15, 2026 - 08:54 CEST

Monitoring

The incident has been resolved and our team is currently monitoring the situation.
Posted Apr 15, 2026 - 08:53 CEST

Investigating

We are currently investigating a partial outage of payment processing across our channels. We will update as soon as there is more information available
Posted Apr 15, 2026 - 08:43 CEST
This incident affected: API, Payments, and MultiSafepay payment pages.