iDEAL outage for SNS/ASN/RegioBank/Revolut
Incident Report for MultiSafepay
Resolved
The incident has been resolved, we'll be monitoring the situation.
Posted Jun 02, 2022 - 13:10 CEST
Update
The situation is improving, most of the banks are at regular performance levels.
Posted Jun 02, 2022 - 13:00 CEST
Identified
iDEAL is experiencing an outage on several banks, SNS, ASN, RegioBank, Revolut, Van Landschot. We are currently monitoring the situation and awaiting resolution by iDEAL.

For more information please also visit https://beschikbaarheid.ideal.nl/
Posted Jun 02, 2022 - 12:51 CEST
This incident affected: Payments.