Customer support - Support over phone is unavailable
Incident Report for MultiSafepay
Resolved
The incident has been resolved.
Posted Apr 25, 2024 - 15:11 CEST
Identified
Due to an issue with our provider, our customer support team is currently unavailable by phone. Please contact our team via email instead.
Posted Apr 25, 2024 - 14:37 CEST
This incident affected: Customer support.