[Bancontact] 3DS authentication performance drop
Incident Report for MultiSafepay
Resolved
The incident has been resolved at the provider at 10:10 CET.
Posted Sep 23, 2024 - 10:42 CEST
Investigating
We're currently investigating a drop in 3DS authentication performance reported by a provider related to Bancontact card payments.
Posted Sep 23, 2024 - 09:00 CEST
This incident affected: Payments.