EXTERNAL - iDEAL: Major disruption at ABN AMRO
Incident Report for MultiSafepay
Resolved
This incident has been resolved.

For more details:
https://availability.ideal.nl/
Posted Jan 22, 2025 - 11:12 CET
Identified
The issuer ABN AMRO is experiencing major conversion issues.

For more details:
https://availability.ideal.nl/
Posted Jan 22, 2025 - 11:01 CET
This incident affected: Payments.