EXTERNAL - iDEAL: Disruption at ING

Incident Report for MultiSafepay

Resolved

The incident has been resolved since 10:11 CET

For more details:
https://availability.ideal.nl/
Posted Mar 19, 2025 - 13:22 CET

Identified

Issuer ING is encountering conversion issues that are causing payment failures.

For more details:
https://availability.ideal.nl/
Posted Mar 19, 2025 - 10:10 CET
This incident affected: Payments.