MultiSafepay MCP performance degradation
Incident Report for MultiSafepay
Resolved
The incident has been resolved. We'll continue the monitor the situation closely and do a review
Posted Feb 18, 2022 - 12:08 CET
Update
We are continuing to investigate this issue.
Posted Feb 18, 2022 - 11:59 CET
Investigating
We are currently investigating an issue on our MultiSafepay Control that prevents some users to login
Posted Feb 18, 2022 - 11:59 CET
This incident affected: MultiSafepay account dashboard and MultiSafepay app.