ING iDEAL outage - iDEAL transactions impacted
Incident Report for MultiSafepay
Resolved
The incident has been resolved by ING.

For more information: https://beschikbaarheid.ideal.nl/
Posted Mar 21, 2023 - 11:32 CET
Monitoring
Performance levels are returning back to regular levels. We'll monitor the situation closely and close the incident once fully resolved.

More details: https://beschikbaarheid.ideal.nl/
Posted Mar 21, 2023 - 11:11 CET
Identified
ING is experiencing an outage impacting iDEAL transactions. Other issuers are not impacted currently.

For more information: https://beschikbaarheid.ideal.nl/
Posted Mar 21, 2023 - 10:49 CET
This incident affected: Payments.