API - Major disruption

Incident Report for MultiSafepay

Resolved

The incident has been resolved.

Our team will maintain on standby to monitor closely.
Posted Jun 06, 2024 - 09:16 CEST

Identified

We have identified an issue in our API affecting payment success rates and general availability.

Our team is working on resolving the situation.
Posted Jun 06, 2024 - 08:12 CEST
This incident affected: API, Payments, MultiSafepay payment pages, MultiSafepay account dashboard, and MultiSafepay app.