Mastercard performance degradation
Incident Report for MultiSafepay
Resolved
This incident has been resolved. Our team will continue to monitor the situation
Posted Jun 16, 2021 - 09:48 CEST
Identified
Mastercard is experiencing issues with 3D Secure. We're currently in contact with Mastercard
Posted Jun 16, 2021 - 09:30 CEST
Investigating
Mastercard transactions are experiencing a performance degradation related to 3DS.
Our team is currently investigating this and will update as soon as possible.
Posted Jun 16, 2021 - 09:26 CEST
This incident affected: Payments.