PayPal Transaction Status issue

Incident Report for MultiSafepay

Resolved

The incident has been resolved.
Posted Oct 07, 2025 - 12:42 CEST

Monitoring

A fix has been implemented, and we are currently monitoring the results to ensure full recovery of PayPal transaction status processing.
Posted Oct 07, 2025 - 12:41 CEST

Investigating

An issue has been identified affecting the processing of PayPal transaction statuses. Our technical team is currently investigating the root cause to restore normal operation as soon as possible.
Posted Oct 07, 2025 - 12:32 CEST
This incident affected: Payments.