[iDEAL] Major performance drop in iDEAL transactions
Incident Report for MultiSafepay
Resolved
The incident has been resolved
Posted Dec 04, 2024 - 10:55 CET
Investigating
We are currently investigating a large performance drop in iDEAL transactions.
Posted Dec 04, 2024 - 10:43 CET
This incident affected: Payments.