[Bancontact] 3DS authentication performance drop
Incident Report for MultiSafepay
Resolved
The incident has been resolved.
Posted Oct 05, 2024 - 21:01 CEST
Identified
The issue at Bancontact has been identified and we are awaiting a resolution from their side.
Posted Oct 05, 2024 - 19:11 CEST
Investigating
We're currently investigating a drop in 3DS authentication performance reported by a provider related to Bancontact card payments.
Posted Oct 05, 2024 - 19:04 CEST
This incident affected: Payments.