iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
This incident has been resolved as of 8:10 CET. We will keep monitoring the situation closely for the next couple of hours.
Posted Nov 04, 2021 - 09:14 CET
Investigating
We have identified a performance drop in iDEAL ING bank conversion. We are investigating the cause.
Posted Nov 04, 2021 - 07:30 CET
This incident affected: Payments.