Full platform outage
Incident Report for MultiSafepay
Resolved
The services are getting back to normal levels. We will monitor the situation and resolve any further issues
Posted Jul 15, 2022 - 16:15 CEST
Investigating
Our platform and services are experiencing a full outage.
We are aware of the situation and our team is investigating, we will update as soon as possible.
Posted Jul 15, 2022 - 16:04 CEST
This incident affected: API, Payments, MultiSafepay payment pages, MultiSafepay account dashboard, and MultiSafepay app.