Bancontact performance degradation
Incident Report for MultiSafepay
Resolved
This incident has been resolved by Bancontact and we’re seeing over the last period normal conversion rates again. Our team will monitor the situation.
Posted Aug 23, 2022 - 14:14 CEST
Identified
Bancontact is experiencing elevated error rates and loss of conversion since 10:50 CET. The issue is identified at Bancontact and we're awaiting resolution. Once we have received an update we'll update the status page here.
Posted Aug 23, 2022 - 11:17 CEST
This incident affected: Payments.