Customer support phone issues
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 09:59 CEST
Identified
We've identified an issue with our incoming phone lines and are currently working on a solution. Please reach out via email if you require support immediately.
Posted Sep 22, 2021 - 09:43 CEST
This incident affected: Customer Support.