Customer support by phone degraded performance
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 15:50 CEST
Identified
Our customer support teams are experiencing connectivity issues with support over phone, we are currently investigating the root cause.
Support via email is not affected.
Posted Oct 04, 2021 - 09:36 CEST
This incident affected: Customer Support.