[iDEAL] Issuer ING is experiencing a major performance drop

Incident Report for MultiSafepay

Resolved

The incident has been resolved at the issuer. We'll be monitoring the situation closely but closing this incident.
Posted Oct 15, 2024 - 11:14 CEST

Identified

iDEAL issuer ING is experiencing major performance issues.
For more details, view https://availability.ideal.nl/
Posted Oct 15, 2024 - 11:08 CEST
This incident affected: Payments.