iDEAL performance issues identified at scheme

Incident Report for MultiSafepay

Resolved

The incident has been resolved at 11:35 CEST
Posted Jul 02, 2026 - 11:56 CEST

Identified

An partial outage on the iDEAL platform has been identified.

For more details:
https://availability.ideal.nl/
Posted Jul 02, 2026 - 11:03 CEST
This incident affected: Payments.