Payout impacted by supplier
Incident Report for MultiSafepay
Resolved
The bank has resolved the issue on their side are processing transfers again and have cleared the backlog, however there can be still a slight delay.
Posted Aug 03, 2021 - 09:26 CEST
Identified
Our bank is experiencing issues with handling the SEPA transfers for the payouts scheduled tomorrow and therefore these will be delayed. As more information will become available this will be reflected here when payouts will be able to resume .
Posted Aug 02, 2021 - 18:41 CEST
This incident affected: MultiSafepay account dashboard.