Mastercard performance degradation for 3D Secure
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 17:29 CET
Identified
The issue has been identified on the MasterCard side. Awaiting resolution.
Posted Jan 17, 2023 - 15:46 CET
Investigating
We are currently investigating elevated error rates on Mastercard transactions with 3D Secure.
Posted Jan 17, 2023 - 15:33 CET
This incident affected: Payments.