Performance issues detected
Incident Report for MultiSafepay
Resolved
Impacted systems have been restored and pending and active notifications are being processed again. Our team will monitor the systems closely in the next couple of hours according to this incident.
Posted Feb 23, 2022 - 17:04 CET
Update
Notifications are temporarily paused and will resume shortly and payments are however being processed.
Our team is working on the resolution and will provide an update as we go.
Posted Feb 23, 2022 - 14:42 CET
Identified
We have identified the issue and are currently working on its resolution.
Posted Feb 23, 2022 - 14:23 CET
Investigating
We are currently investigating reports of degraded performance on our Merchant Control.
Payments are unaffected and our team is investigating the issue.
Posted Feb 23, 2022 - 14:09 CET
This incident affected: API, Payments, MultiSafepay account dashboard, and MultiSafepay app.