iDEAL performance issues identified at issuer ABN AMRO, ING

Incident Report for MultiSafepay

Resolved

The incident has been resolved.
Posted May 20, 2025 - 13:46 CEST

Update

Issuer ING has been also been reporting performance issues.
Posted May 20, 2025 - 13:22 CEST

Identified

For more details:

https://availability.ideal.nl/
Posted May 20, 2025 - 13:07 CEST

Investigating

We are currently investigating a performance drop at issuer ABN AMRO.
Posted May 20, 2025 - 12:52 CEST
This incident affected: Payments.