Mastercard performance degradation - payments affected
Incident Report for MultiSafepay
Resolved
We are closing this incident report - approval rates have been performing at regular levels since 22:41 CET
Posted Aug 15, 2022 - 22:45 CEST
Monitoring
Approval rates are at a regular level, the issue appears to be caused outside of our infrastructure. We'll keep monitoring the situation.
Posted Aug 15, 2022 - 20:52 CEST
Investigating
We are currently investigating a drop in payment approval rates on Mastercard payments since 20:23 CET. Once we know more we'll update the status of this incident.
Posted Aug 15, 2022 - 20:33 CEST
This incident affected: Payments.