iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
The incident has been resolved by ING as of 12:10 pm. Performance is again at nominal levels our team will monitor the situation closely.
For more details
https://beschikbaarheid.ideal.nl/History?bank=ING
Posted Feb 22, 2022 - 12:55 CET
Identified
We have identified that ING is experiencing an outage, other bank do not seem affected. Our team will monitor the situation.
For more information:
https://beschikbaarheid.ideal.nl/
Posted Feb 22, 2022 - 09:04 CET
This incident affected: Payments.