PayPal performance degradation
Incident Report for MultiSafepay
Resolved
PayPal transactions are processing at regular levels again. Our team will monitor the situation closely.
For more information: https://www.paypal-status.com/history/eventdetails/31132
Posted Apr 08, 2021 - 20:00 CEST
Identified
PayPal is experiencing a performance degradation and therefore PayPal transactions are failing. Our team is currently monitoring the situation and will update as PayPal restores it services. More information: https://www.paypal-status.com/product/production
Posted Apr 08, 2021 - 19:09 CEST
This incident affected: Payments.