Mastercard performance degradation for 3D Secure
Incident Report for MultiSafepay
Resolved
This incident has been resolved
Posted Nov 30, 2022 - 11:20 CET
Monitoring
MasterCard is performing almost at normal levels, we are awaiting confirmation of resolution by MasterCard to resolve this incident.
Posted Nov 30, 2022 - 10:59 CET
Identified
The issue has been identified on the MasterCard side. Awaiting resolution.
Posted Nov 30, 2022 - 09:57 CET
Investigating
We are currently investigating elevated error rates on Mastercard transactions with 3D Secure. Source of the issue appears to be on MasterCard side.
Posted Nov 30, 2022 - 09:46 CET
This incident affected: Payments.