iDEAL performance issues identified at issuer Rabobank
Incident Report for MultiSafepay
Resolved
The incident has been resolved by the issuer Rabobank.

For more details

https://beschikbaarheid.ideal.nl/History?bank=Rabobank
Posted Jan 03, 2024 - 11:18 CET
Identified
iDEAL issuer Rabobank is experiencing significant conversion issues, MultiSafepay is standing by on resolution by issuer.
For more details

https://beschikbaarheid.ideal.nl/History?bank=Rabobank
Posted Jan 03, 2024 - 09:52 CET
This incident affected: Payments.