Resolved Service Incident – sFTP report delivery

Incident Report for MultiSafepay

Resolved

We identified an incident affecting report delivery over sFTP between 18:00 CEST on 16 June and 08:30 CEST on 17 June.
The issue has now been resolved. Any report subscriptions that were impacted during this period can be re-executed.
Posted Jun 16, 2026 - 18:00 CEST