iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
The incident appears to have been resolved by ING. Our team will monitor the situation closely.
Posted May 08, 2023 - 11:52 CEST
Identified
An issue has been identified at iDEAL issuer ING, we're awaiting resolution by ING.
For more details: https://beschikbaarheid.ideal.nl/
Posted May 08, 2023 - 11:21 CEST
This incident affected: Payments.