PayPal transactions are experiencing issues

Incident Report for MultiSafepay

Resolved

PayPal has resolved the issue
Posted Oct 16, 2025 - 18:53 CEST

Identified

PayPal is experiencing issues, payments are not being completed. MultiSafepay is standing by for a resolution from PayPal
Posted Oct 16, 2025 - 17:47 CEST
This incident affected: Payments.